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1. MEMBERSHIP MANAGEMENT 

 

There are 2 ways to open this application.  
 

1. From your Legend desktop open the Legend Membership Management icon. 
2. When you have a member in your passport in Front of House you will have the option in 

the passport for “Member Admin”, this loads the current member directly into 
Membership Management. 

 

1.1. OVERVIEW 

 

To the left of this application is the function bar, any action relating to a member can be found 

in this column.  

 
Along the top you have various tabs, by default you will always start on the ‘Member Data’ tab, 

you will click through these tabs to see various information about the member. 

 

 
 

At the top left of this application you will see a gold padlock icon, when you click this you are in 

edit mode, this allows you to change certain member details such as home address, phone 

numbers etc. While in this mode you can click the padlock again to undo any changes or the 

green save icon that appears to save your changes.  

 
 

Along the bottom you will have several key bits of information such as the member balance, 

member status, member issues and the current user that is logged into Legend. 



 

 
The white box with the magnifying glass is the search field, this works in the same way as Front 
of House and accepts the members name (surname first), member number or barcode number.  
 

1.2. MEMBERSHIP MANAGEMENT TABS 

1.2.1. MEMBER DATA 

 

This tab allows you to view / edit basic member details such as their name & contact details, 

you can also update medical preferences using the ‘Medical Info’ button towards the bottom 

right. Please note that you should not change the ‘Status’ as this will automatically change 

depending on any agreement actions that occur. 

1.2.2. AGREEMENT 

 
Agreement Detail: 
 
From here you will be see the agreement the member is currently on and any historical 
agreements. You can use the small green/yellow icon to see the full details of the agreement 
the member is on and you can use the red/green arrow icon to see any historical agreements. 
 
Agreement Information: 
 
Here you can see all of the current agreement dates, the Last Use Date determines when the 
membership will lapse if they’re a paid-in-full member, direct debit memberships will not lapse 
until you use the termination wizard to manually lapse them. 
 
Payment Information:  
 
Shows the payment dates, payment cycle and type and the autobill option.  
 
If autobill is ticked then the membership will NOT lapse unless you use the termination wizard, 
this is usually selected by default for direct debit & casual memberships. 
 
Fees: 
 
The only fee you should change here is the Periodic Payment, this is the cycle fee. 
 
Contract Dates: 
 
Signed date – Is the date the member ‘signed’ their agreement contract. 
 
Termination Date – This will show the date the agreement is due to or previously has lapsed, if 
you wish to cancel a future lapse you can use the edit button (padlock) and then delete the 
date from this field. If the member is already lapsed then you should use the ReActivate wizard 
and then the Upgrade wizard. 
 
Termination Reason – The selected reason for lapsing the agreement. 



 

 

1.2.3. ACCOUNT DETAILS 

 

Bank Details: 
 
This where you will be able to create/add a new bank account for a member’s DD.  
 
Payment Information: 
 
Will display the Cycle Fee (How Much the member is paying a month), Payment Type (DD or 
Paid In Full), Final Payment Date (When their final payment is), Next Payment Due (When their 
next payment is gone be due), Total Next Payment (How much they have to pay on their next 
payment) and you have a Collect All option which allows you to collect all the outstanding 
money from the member if they are on a DD. 
 
Freeze History: 
 
This will show you if the member has any current or future freezes on their account. Here you 
can delete a freeze, change the end and start date of the freeze and a tick box to Prevent Use 
to your centre for the freeze period. 
 
Account Activity: 
 
From here you will be able to see a statement showing you the Activity on the member 
account. 



 

1.2.3.1. ADD NEW BANK DETAILS 

 

To add new bank details to a member please follow these instructions: 

 

 Make sure you have the correct member in Membership Management > Select the 

Account Details tab > Click the edit button (padlock). 

 

 Select ‘Create New Account’, this will automatically generate a new bank reference and 

will change the BACS code to ‘00 – New not Valid’. 

 

 Enter the account details > Select ‘Verify Branch Account’ > Select the save button (next 

to the padlock).  

 

 It is important that you do not manually change the BACS code, it will update 

accordingly automatically. 

 

 
 
 
 
 
 
 
 
 
 
 



 

1.2.4. CLUB USAGE 

 
When a member swipes their membership card (including manual swipes) at Front of House or 
any gates / turnstiles connected to Legend then you can view these swipes on this tab. 
 

 

1.2.5. CREDIT CONTROL 

 
This will detail if a member has a debt against their account and how long it has been 
outstanding. 

 



 

1.2.6. MARKETING 

 

This screen populates the information given in the new member wizard the goals and interest 
of the member. You can edit any of these using the edit (padlock) button. 
 

 
 

1.3. ADDING NEW MEMBERS 

 
New (Head) Member 
 

 To add a new member to Legend > Click on ‘File’ (located on the left in the function bar) 
> Select ‘New Member’ and then follow the instructions below: 
 

 
 

 Click next on the first step and on the second step you can select the member’s home 
club.  

 

 Click next once home club has been selected. 
 



 

 On the next step you will then enter the member’s Card Number, Title, Forename and 
Surname in. The Membership number will be automatically created once filled in then 
click next. 

 

 The next step is where you will enter the member Personal Details in as Date of Birth, 
Ethnic Origin etc, click next once completed. 

 

 The following step will ask you to enter the member’s Contact Details, you can enter the 
Postcode in and click on the search button which will show the address’s to choose 
from, click next when done. 

 

 The next step will involve you entering in the Marketing Information, click Next when 
filled in. 

 

 The following step will ask you to enter in the Medical Information of the member, click 
next when done. 

 

 On the next step you need to fill in the Membership Agreement Details i.e. Contract Sign 
Date, Member completed Medical Questionnaire, if the member was referred by 
another member you will enter the Referring Member number in, then click next. The 
following step is where you will be asked the Agreement Type, Agreement Pricing and 
the Payment Method the member is going onto. The Agreement Period is automatically 
generated for you but this can be changed if required, click next when done. 

 

 The next step will show Eligibilities for the member if any Eligibility has been setup for 
that agreement, if not it will just be blank; you can just click next on this step. 

 

 If there are any Bolt On Services as towels or locker you will have the option to select 
the Bolt On if the member requires them, click next when done. 

 

 The next step is where the charges are being created automatically for the agreement 
i.e. Admin fee, Prorate, Up Front Cycle Fee and Cancellation fee. All these charges can 
be overwritten if the user has the correct security token. Prorate is automatically 
calculated, you can just click next on this step. 

 

 The following step is just a confirmation of the member details and the agreement, click 
next. 

 

 On the next step you have the option to print off the agreement document, to preview 
the agreement document (if these are configured in your Legend system); you also have 
a tick box to check if the member has signed the membership form, it is important that 
you tick this so that the members status is set to Active, click next when done. 

 

 Then on the final step you will be presented with a Final Summary, click on the FINISH 
tab once reviewed. 

 
Once you have completed the New Member Wizard the members details will automatically 
populate Membership Management. 
 



 

You can then search for the member in Front of House and pay off any membership fees that 
they might have outstanding. 
 
Add On Members 
 
If you use add on members it’s important that you create the head member first: 
 

 Search for the head member / head payer using the search box at the bottom of 
membership management > Click on ‘File’ (if it’s not already expanded) > Select ‘AddOn 
Member’. 

 

 This will open a wizard very similar to the one used to create the head member, you will 
see that it has already pre-selected ‘Add to existing membership…’ and has populated 
who will be paying for the membership. 

 

 
 

 Click ‘Select Membership’ > The box below will open > Pick the applicable option from 
the top drop down menu > Make sure the agreement pricing is correct > Billing Method 
will always be the same as the head payer. 



 

 
 

 You can then continue the New Member Wizard to add this member to the head payer. 
 

 

1.4. AGREEMENT ACTIONS 

 
There are various other wizards in Membership Management that allow you to perform actions 
to members agreements, these are all located in the function bar under the ‘Actions’ header 
and are explained in greater detail in the next section.  
 
Upgrade 
 
Think of the upgrade wizard more of a change wizard in that you can upgrade, downgrade or 
even renew your membership. Please note that you can only use this action on active members 
(reactivating members is covered later in this section). 
 
The upgrade wizard works in exactly the same way as the new member wizard that we have 
already covered, the difference is that it will take you almost straight to the agreement 
selection screen where you can pick a new agreement for the member.  
 
Once you have completed this action the member will be immediately changed unless you 
specified a future start date in the wizard. It will also add any outstanding charges to the 
members account. 
 
Renew 
 
This wizard works in the same way as the upgrade wizard described above but will only start 
the new membership after the end of the current membership contract. Mainly used for paid-
in-full agreements. 
 
Freeze 
 
The freeze wizard allows you to freeze memberships for a specified amount of time, if the 
member pays by direct debit you will also have a choice to charge the member a smaller 
monthly fee. These functions vary per site configuration. 
 



 

Link 
 
If you wish to link existing members together you should use this wizard, useful when you’re 
creating an add on member but they already exist on the system. 
 
Terminate 
 
Use this wizard to lapse members, if you leave the lapse date as today then they will lapse once 
you complete the wizard and if you select a future date it will lapse at midnight the day before. 
 
ReActivate 
 
A very quick way of reactivating a lapsed / terminated member, please make sure you use the 
upgrade wizard afterwards to upgrade / change / renew their membership. 
 
UnLink 
 
This will unlink the selected member from the head member and will automatically lapse the 
agreement. 
 

1.5. UPGRADE WIZARD 

 

To change a members agreement (upgrade or downgrade) you should use the Upgrade Wizard.  

 

 First load the member you wish to change into Membership Management. 

 From the action bar on the left side of the application select ‘Upgrade’. 

 Click next through the wizard, you will notice this is the same process as the new 

member wizard except that it skips a few steps.  

 Once you reach the agreement screen you can change the members agreement and 

start date for the new agreement.  

 If you do not change the date and leave it as todays date, then the change will take 

effect as soon as you finish the wizard. 

 You will have an option to review the fees and override them if you have the relevant 

security token. 

 

1.6. RENEW WIZARD 

 
To renew a members agreement (if using the same billing method such as paid in full > paid in 
full) you should use the Renew Wizard. 
 

 First load the member you wish to renew into Membership Management.  

 From the action bar on the left side of the application select ‘ Renew’. 

 Click next through the wizard, you will notice this is the same process as the new 

member wizard except that it skips a few steps.  

 Once you reach the agreement screen you can change the members agreement and 

start date for the new agreement.  



 

 If you do not change the date and leave it as todays date, then the change will take 

effect as soon as you finish the wizard. 

 You will have an option to review the fees and override them if you have the relevant 

security token. 

 

1.7. FREEZE WIZARD 

 
Legend offers the ability to freeze a membership for a set period of time. This is primarily used 
for freezing direct debit membership payments to a set cycle fee.  
 
Please bare in mind that you cannot freeze a member that has any outstanding debt or is 
pending / lapsed / terminated.  
 

 From the action bar on the left side of the application select ‘Freeze’. 

 This wizard will ask for a freeze reason and a freeze type.  

 Next it will ask for how long you wish to freeze the member (in months), it will ask for a 
cycle fee to be entered (depending on configuration this might already be pre-set).  

 You have the option to allow or deny access to the club during freeze, if you allow 
access to the club while frozen, no message will appear when the member swipes in 
through FOH. If they are not allowed access then a message will appear on the Member 
Control screen in FOH and they will be denied access through any gates / turnstiles.  

 
For a direct debit payer you can see if you freeze has been actioned correctly by selecting ‘Fwd 
Billing’ under the Accounts tab located to the left side of the application. It will show you which 
months have been effected and what the cycle fee has been changed to.  
 
To cancel a freeze go to the Freeze History section on the Account Details tab and click Cancel 
Freeze, press the cross on the top left hand side and you can then chose a date a reason why 
you’re cancelling the freeze. 
 

 
 
 
 
 
 
 



 

1.8. LINK WIZARD 

 

The Link Wizard will be used to Link two membership accounts together. Within the wizard you 
will have two different options, Add On and Linked. 
 
Add On - You will use this option to Link two members together, both members can be on 
separate agreements and you will have the head member paying for both agreements. 
 
Linked - This option will be used to once again Link two member accounts together but the 
difference is that both members will need to be on the same agreement, the head member will 
be paying for both agreements 
 

1.9. TERMINATION WIZARD 

 
The Termination Wizard will allow you to lapse a member immediately or on a future date of 
your choice.  
 

 From the action bar on the left side of the application select ‘Terminate’. 

 Click through the wizard to select a termination reason & termination date. 

 You will be asked if you wish to lapse the member or terminate, best practice is to leave 
this option set at the default setting of ‘lapse’. 

 
 

1.10. REACTIVATE WIZARD 

 
The ReActivate wizard will allow you to reactivate a lapsed, cancelled or terminated member.  
 

 From the action bar on the left side of the application select ‘ReActivate’. 

 This is a very simple wizard where all you are required to do is click next and then finish.  

 Once you have reactivated a member it’s important to remember to then upgrade or 
renew their membership. 

 

1.11. UNLINK WIZARD 

 
The Unlink wizard will allow you to unlink an add on or linked member from the head member.  
 

 From the action bar on the left side of the application select ‘Unlink’. 

 It is important that you make sure you have the member you wish to unlink already 
loaded in membership management, if you wish to double check you will see the 
membership number and member name along the top bar of the Membership 
Management application.  

 This is yet again a very simple wizard where all you’re required to do is click next and 
finish to confirm the unlink.  
 
 
 

 



 

1.12. OTHER NOTEABLE MEMBERSHIP MANAGEMENT FUNCTIONS 

1.12.1.           CHECK IN NOTE 

 
If you wish to add a permanent note to a members account you can use the padlock to unlock 
the various fields and you can enter a note into the Check In Note box. This will appear on the 
Member Control screen of Front of House until it is removed from this field. Remember to click 
the save icon once you’ve entered / edited your note.  
 

 

1.12.2.           ADDING A NOTE  

 
You can add a note to a members account that can only be seen within Membership 
Management.  These appear under Comms > Events.  
 
To add this Select Comms > Note > Enter your note and click Create. 
 

 
.  
 
Another way to add a note is to simply put the page into edit mode and then add a note under 
the agreement tab. However, this wont date stamp or be traceable if someone changes or 
deletes it. 
 



 

1.12.3.           EVENTS  

 
Comms > Events 
 
Here you can see any event that has occurred on a members account such as a member swipe, 
change of agreement, booking made. It can all be seen in this area. You can also double click an 
event line and it will provide more details such as which user performed the action, at what 
time and date.  
 
Events are also searchable on the criteria below: 
 

 Resolved / unresolved 

 Specific  time frame 

 By category – bookings / billing / system / communication / other 
 

1.12.4.           CLEAR DEBT 

 
If for any reason you need to clear a members debt for membership fees, booking / course 
charges you can select Accounts > Payments.  
 

 Simply select the line/s you wish to clear debt for, these will then be highlighted in blue 
and you’ll notice that the ‘Amount’ section will automatically populate.  

 Don’t change the ‘Type’ field. 

 You may change the ‘Analysis’ field, when you clear a debt it will be cleared against this 
GL / Nominal code so that you can report on it. 

 Type in a note to say why you’re clearing the debt.  

 Click ‘Apply Payment’ 
 

 



 

1.12.5.          RAISE A CHARGE 

 
If you wish to raise a charge against a members account select Comms > Charges 
 

 Type in a note as to why you’re raising a charge (this will be logged in events). 

 Enter an amount. 

 Choose an Analysis code to set the debt against. 

 Select ‘Apply Charge’. 

 You will now see this debt in Front of House and can pay for it there. 
 
If you were to select ‘Apply Charge and Pay’ it will apply the charge and then open the Payment 
window to clear the debt.  
 

 

1.12.6.           STATEMENT  

 
The statement can be found by selecting Accounts > Statement. 
 
In here you can view a history of: 
 

 Membership Fees 

 Secondary Spend 

 Bookings  

 Credit Notes 
 
You also have the option to print a page of the statement if required.  
 
Please note it is not advised to use the ‘Credit’ or ‘Refund’ buttons. There are better ways of 
doing this as described in previous sections. 
 
 
 



 

1.12.7.           CREATE A CREDIT NOTE 

 
When in the members Statement > Select ‘Credit Notes’ tab > Click ‘Create’ that’s located 
towards the bottom right.  
 
A box will appear asking for an amount and a reason (if reasons are configured in your Legend 
system), enter your amount and click create.  
 
To clear a credit note simply click the credit note line that has been created, on the popup box 
select ‘Clear’. 
 

 
 

1.12.8.           ACCOUNT SEARCH 

 
Accounts > Acc Search 
 
This allows you to search for members that use specific bank details, used mainly to check for 
duplicate accounts. 

1.12.9.           ADVANCED SEARCH AND MAIL MERGING 

 
The little man icon holding the magnifying glass at the top of the screen in Member 
Management allows you to perform an advanced search for members.  
 
Mail Merge can also be done from the advanced search. In order to do this input your search 
criteria and click on search, you must then click on select all and then merge.  
 



 

Once the mail merge box has opened choose the template you wish to use by clicking on the 
template box with the three little dots. You can then either view the documents or print them. 
If you tick to ‘Record to Comms history’ then the letter will be recorded for future audit 
purposes within Events. 
 

 
 

1.12.10. DIRECT DEBIT FUTURE PAYMENTS 

 
Accounts > FWD Billing 
 
Only used for direct debit payers, it will show the next 2 years of monthly billing, very useful if 
you have applied a freeze to a members account and you wish to see if you have applied it 
correctly or even to print and give to the member. 
 

1.12.11. ONLINE ADMIN 

 
If you take advantage of Legend Online Services then you’ll be able to link or unlink an email 
address to a members account and reset their password.  
 
 

 



 

2. LEGEND BOOKINGS 

 

2.1. OVERVIEW 

 

The Legend Bookings application is where you can schedule & configure classes, activities & 
courses.  
 
The Resources section represents the booking structure that will be viewed in Front of House 
Bookings, for example Classes will always be under Activities > Classes and your Ad-Hoc 
activities will always be bookable directly into the location.  
 

 
 

You will also notice the calendar, this is the quickest way to navigate to a specific date.  
 

 
 
Along the top of the booking timetable you can change your timetable view. 
 

 
 

2.2. CLASSES 

2.2.1. SCHEDULE A CLASS 

 
Navigate in the Resources section to Activities > Classes > Select a class.  
 
You’ll notice that when you select a class that the timetable will no longer be grey and will be 
highlighted in orange. If the time table is ever grey it means that either the time is in the past or 
the class is setup not to be bookable on that day at that time.  



 

 

 
 
To schedule a single instance of a class simply double click on the orange timeslot of your 
choosing.  
 

 

 
This will open the Booking Reservation, in here you can change the name of the reservation if 
you wish, edit the start date / time & duration of the class.  
 



 

 
 
At the top right in the Linked Resources box more often than not you will see ‘sub types’, if you 
double click on these subtypes a box will appear (as above) asking where you would like to 
book the class and / or which instructor you would like to link to the class, if your bookings 
system is setup this way it offers greater flexibility when scheduling a class however it will work 
just fine linked directly to the physical area and/or instructor. 

2.2.2. SCHEDULE A RECURRING CLASS 

 

Most classes will be on a set schedule and bookable at least once a week at the same time. To 

create a recurrence for a class: 

 

 Navigate in the Resources section to Activities > Classes > Select a class.  

 Select the date you want the class to begin and then double click on the orange timeslot 

you require. 

 As before, pick the linked resources (saying which physical locations the class will use) 

from the top right box, 

 Select the ‘Recurrence’ tab, you then have the option of ‘Daily’ or ‘Selected Dates’.  

 The most common option is to select daily, then you can choose that the class is on for 

every 7 days for X amount of weeks. We recommend that you don’t exceed 100 

occurrences.  

 Click ’OK’, a prompt will appear asking if you wish to book this recurrence, select ‘YES’. 

 



 

 

2.2.3. AMENDING A CLASS 

 
 

 
 
Once the booking has been created it will appear on the booking sheet. 
 
You can amend the time, date, duration, capacity and inventory item by double clicking on the 
booking.  
 
Make any changes then click onto the ‘Advanced’ tab, here you will see that you can then apply 
these changes to just this booking, X amount of bookings or all future instances.  
 
Make your choice then click OK to apply the changes. 



 

2.2.4. RECALLOCATING A BOOKING  

 
If you need to change a location of a booking or an instructor right click on the booking and 
select ‘Reallocate Booking’. You can then change to the required area or instructor. This can be 
applied for only this one instance, all future instances or for a certain number of instances.  
 
Select Update to confirm your changes.  
 
Please note that you can only update one line at a time.  
 

 
 

2.2.5.  CANCELLING A CLASS 

 

 Double click on the class you wish to cancel (or the first instance if cancelling multiple). 

 Change the Status box to Cancelled. 

 Select the Advanced tab. 

 Choose if you wish to cancel just this instance, X number of classes or all future 
instances. 

 Select OK. 

 You will receive a prompt asking if you’ve informed anyone booked onto the class that 
you’re cancelling it, select Yes. 

 Another prompt will appear to make sure you definitely want to cancel, select Yes. 
 

 
  
 
 
 
 



 

2.3. BLOCK BOOKINGS 

2.3.1. CREATE A BLOCK BOOKING MEMBER (CORPORATE SPONSOR) 

 

Before creating a block booking you must have a block booking member, this is usually the 
name of the group that would be making the booking such as Manchester Swim Club etc.  
 
To create a new Block Booking member: 
 

 Open Membership Management 

 Select File > Corporate Sponsors 
 

 
 

 Here you will see any existing Block Booking members, by default you will view the 
Enterprise members, you can select to view the regional or club specific members using 
the tree on the left.  
 

 



 

 Select ‘Add’ to create a new member.  
 

 
 

 Enter a Name and Alt Code, the Alt Code is usually the same as the name however can 
be used for anything you wish.  

 ALWAYS tick Booking Corporate, if you do not do this then you will not be able to use 
this member for a Block Booking. 

 Fill out the details on the Contact Details tab. 

 Click OK. 
 
It’s usually best practice to prefix the Name field with “BB –“ when you search for this member 
you can simply then just type in BB and all of your block bookers will appear first in the search. 
 

2.3.2. CREATE A BLOCK BOOKING 

 
 
You can make a block booking for anything that isn’t a class, such as badminton in a sports hall 

or a spa treatment with a therapist. 

 

 In Legend Bookings browse in the resource tab to ‘Location’ or ‘Booking Sheet’ (some 

clubs have this named differently). 

 When you expand this tree you will see all of the physical resources available at your 

club, if you expand if further you will see the specific areas of those physical resources. 

  



 

 
 You can click on the header or an individual area to load the booking sheet for that 

specific resource.  

 RIGHT CLICK on the time you wish to book select BLOCK BOOKING and a member 

search will appear, ONLY your Block Booking members will appear in this search, if 

normal members appear then you haven’t right clicked and selected block booking.  

 

 
 Select the member you wish to make a booking for and the usual booking screen will 

appear.  

 Select the ‘Recurrence’ tab and enter the duration of the booking.  

 Click OK once you have completed your selections.  

 If there is a cost associated with the inventory item linked to the activity then a pop up 

box will appear asking how to charge the member, you will have 3 options.  

 



 

 Single Charge – This will total up the whole cost of the booking and add a lump sum of 

this debt to the members account. 

 Charge Per Session – Will split the cost into a price per session. 

 Invoice – This will not invoice the member, it is used to override the price of a booking. 

For example, if you’re creating a 10 week booking and enter £100 into the Invoice field, 

it will divide this amount by however many sessions that you’re booking, in this case it 

would charge the member £10 per week.  

 Click OK, once you’ve made your selections and Yes to any further prompts to create & 

confirm the booking. 

 

If you have created your booking correctly it will display the Corp icon and look like below. 
 

 
 
 

2.3.3. CANCELLING A BLOCK BOOKING 

 

Cancelling a block booking differs slightly from cancelling a class or normal activity.  

 

 Double click on the first instance of the booking you wish to cancel.  

 Select the member that is booked in. 

 Select ‘Cancel Booking’. 

 A popup will appear asking which sessions you wish to cancel. Make your choice and 

then Click OK.  

 

 



 

 You’ll notice that the member is no longer in the booking and the status has changed to 

Cancelled, click OK to confirm you wish to cancel and yes to any further prompts.  

 If you do not cancel a block booking this way it might leave the debt on the account. 

 

2.3.4. PAYING A DEBT 

 
Paying a members debt for a block booker is the same as paying debt for any member.  
 

 Open Legend Front of House. 

 Search for the block booking member. 

 In the member passport select ‘Member Info’. 

 The screen below will appear, select the green ‘Billing’ icon on the left side to display 
any outstanding debt the member owes. 

 

 
 

 Select the debt you wish to pay for and make your payment option to the right, you can 
part pay, pay or pay all.  

 This will add the debt to the basket for you to pay off like any other transaction. 
 

2.4. EXPORTING & IMPORTING COURSES 

2.4.1. EXPORTING COURSES 

 

Before we can create a new term for a course we must export them in order to create a 
template.  
 

 Open Legend Bookings 

 Select File > Import/Export > Export Course 
 



 

 
 
 

 Add the courses you wish to export to the right hand box using either the > icon or >> to 
move all.  

 Adjust the dates to capture the data from the previous courses in that date period. 
 

 
 
 

 Select Next . 

 The file path is asking you where you wish to save the file, you can save this onto the I:\ 
drive within Legend. Select Browse and choose the folder you wish to save it then name 
your export file. 

 Select Export. 
 



 

 
 
 

 You should now minimise Legend Bookings so that you’re on the Legend desktop. 

 Open the ‘Computer’ icon and browse to the location you saved the file to open it up. 
 

 

 
 

 Here you can change various details such as the name of the course, term, linked 
instructors, inventory item etc.  



 

 To prepare the document for importing the start date of the terms must be changed to 
the new term dates. 

 

 
 

 Make sure you delete any lines that you don’t wish to import then Save & close the file. 
 

2.4.2. IMPORTING COURSES 

 
 

 Open Legend Bookings 

 Select File > Import/Export > Import Course 

 Use the Browse button to find the template that you have just completed. 

 Select ‘Next’ then Select ‘Process’. 

 This will now check for any errors, a message will appear in green to say the file has 
been successfully processed if there are no issues, if there are issues it will tell you 
which line the error is on so that you can go back to your excel template and correct the 
mistake.  

 If your file was processed successfully click ‘Next’ and then select ‘Finish. 
 
If you attempt to double book a physical resource or instructor a message will appear to inform 
you the specific resource, date and time so that you may go correct this. 
 

2.5. HOLIDAY MANAGEMENT 

 
Holiday Management allows you to remove selected day from being bookable for days you are 
closed such as Christmas day. 
 

 Open Legend Control Panel. 

 Select ‘Data’ > Holiday Management. 
 



 

 
 

 Select New to create a new holiday profile. 

 Give the profile a name then select the ‘Holidays’ tab. 
 

 
 

 You can now add in dates on an Enterprise, Group (region) or Club specific level. 

 Once all of your dates have been added click OK.  

 You might need to close and reopen Legend Bookings to see the changes.  
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3. REPORTING 

 

Legend Reports presents in a tree-view format with category folders and sub-folders of report 
types and reports. This ensures that you can quickly find a report despite there being many to 
choose from. There is also a ‘My Reports’ folder where you can save the reports that you most 
commonly run. 

 

3.1. RUN A REPORT 

 

To generate a report, simply follow the steps below: 

 Open the Legend Reports application. To do this, select the Reports Icon on your desk-top 
view.  

 Select the category that you want by selecting the relevant folder; for instance, if you 
want to find a Problem Swipe Report, then select the folder OPERATIONS. 

 Select the sub-category or report type that you want by selecting the appropriate 
description within the list in the folder. For instance under OPERATIONS, you may select 
DAILY REPORTS. 

 Select the report folder type that you want, for instance OPERATIONS/DAILY 
REPORTS/Problem Swipes. 

 Either select ‘Run’ for a standard daily report, or be specific with the range [for example, 
selecting only those members who pay by Direct Debit]. 

 You can also select selection parameters that you want, using the selection tab. For 
instance you may want to run the report for a date range, or for yesterday, or for a future 
date. Similarly, you may want it to include new fields or data. Select [Run]. 

 The report will be generated in an Excel view. If you want to work on it further then select 
the Excel Write option [located on the toolbar], which converts it to a standard Excel 
document for you to save, print or format. 

 

3.2. SAVE A REPORT (MY REPORTS) 

 

If you have several reports that you use on a regular basis, you can save these under My Reports, 
thus eliminating the need to navigate and alter the parameters every time. 

 Prepare your report as normal (selecting those parameters you require) 

 There is no need to run the report, simply go to File > Save, you will then be asked to 
specify a name for this report. 

 Enter a relevant name for the report and hit Save 

 The report is now accessible every time you log on to reports underneath My Reports 
(the first tree in left hand frame) 
 
 



  Page 35 

 

 

 

3.3. CUSTOMISING EXISTING REPORTS 

 

Legend Reports enables you to include the specified columns you would prefer to see in your 
report. 

 

To include customized columns 

 Select the report you wish to run. 

 Open the Tools menu and click Customise Columns. This is also the best way to see what 
is included inside a report. 

 You will be presented with a dialogue box. On the left you will be able to view all the 
columns available to be included in your report. The right will display columns already 
included. 

 To select additional columns, select the name of the column on the left and then select 
the [Add] button. 

 Click [Ok] and run your report as normal. 

 

 

By using new Range and Selection Parameters, many new reports can be generated from existing 
reports. 

 

EXAMPLE: RUNNING A PROBLEM SWIPES REPORT 

 Open application by selecting Legend Reports icon on desktop  

 Select Operations Folder and select Problem Swipe sub-folder from the list on the left. 

 Select ‘RUN’ if you are happy with the range and selection parameters defaulted [most 
often the report will be ready to run].  

 Alternatively, select the Range and Selection parameters yourself. First select the Range 
tab at the top of the screen. Then choose the range in the dialogue box that appears (for 
example, you could choose only bronze members) 

 Then select the Selection tab at the top of the screen. Select the parameters you want 
from the dialogues (for example, you could specify only male members) 

 Select ‘Run’ once you have made your selections.  

 

The completed report is produced. If you wish to convert it to Excel Worksheet for printing, or 
formatting or saving, then select the Excel icon which can be found on the toolbar at the top of 
the screen.  
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3.4. RUN A REPORT FOR MAIL MERGE 

 

 Prepare your report as usual and select the Run button. 

 Select Run for Merge from the Reports menu. 

 You will be presented with a Reports Merge Wizard. Select ALL by selecting the ‘Merge 
All’ check box at the bottom of the screen. Alternatively, highlight the specific members 
in the list to be included in the merge. Click [Next] 

 Select the Template to merge to, insert a Regarding (to be displayed in member 
communications) and then select either to View, Print, Email or Save the file. 

 Select the Merge button and the records will be merged to the required template. 

 

3.5. SCHEDULE REPORTS 

 

Legend Reports enables you to schedule reports to run automatically at pre-planned intervals. 
The reports can either be saved to a central folder or alternatively the reports can be emailed 
automatically to a predefined list of recipients. 

 

To schedule a report to run automatically 

 Prepare your report as normal but rather than selecting Run do the following: 

 Select Schedule from the Special menu. 

 You will be presented with a Schedule Reports dialogue box from which you can edit 
current scheduled reports or add new reports 

 Select Add New 

 Give the scheduled report a name and tick the Enable Schedule box 

 Select the other criteria according to your requirements and choose a location on the 
server in which to copy the folder to 

 Windows scheduler now needs to be configured to set up the tasks (you can define such 
settings as the day, frequency, duration and desired output) 

 When you are happy with the scheduled report, click [Ok] to save it 

 

Popular Reports are:   

 Category Summary Report – allows you to look banking for certain days  
Standard – POS Reports – Category Summary 

 Income Journal – Allows you to look at the banking for certain time period under different 
categories  

Standard – Financial Report – Income Journal 

 Active member List  
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standard – memberships – member list report – member status – active members 

 Ex Member List  
Active member List standard – memberships – member list report – member 

status – cancelled members 
 

We also have further documentation on income reporting & more common reports available 

from www.legendreleases.co.uk  

http://www.legendreleases.co.uk/

